PCI Express Parallel Port Card /w Full & Lowprofile Brackets SPP/EPP/ECP (TPE-PCIEPARAL)

PCI Express Parallel Port Card /w Full & Lowprofile Brackets SPP/EPP/ECP (TPE-PCIEPARAL)
Have an old printer? Need to add a parallel port? Get our GNU/Linux supported PCI Express card.

  • Mainline kernel & linux-libre supported

  • Support for popular and libre (free) distributions

  • Not dependent on wrappers, binary blobs, or proprietary drivers-firmware

  • Up to 1.5 Mbps Data Transfer Rate

  • Full & low profile brackets included

  • Model TPE-PCIEPARAL



Fast shipping: In the United States or Europe?
Get it in as little as 1-5 business days!
And within 6-10 for most other major destinations world wide

Category Specification
Chipset Oxford PLX OXPCIe952
Standards Supported SPP/EPP/ECP
Data Transfer Rate Up to 1.5 Mbps
Supported Kernels Linux 2.6.32 and later
Compatible With Windows 95, 98, ME; Windows XP (32-bit, 64-bit), Windows Vista (32-bit, 64-bit)


Have questions?
E-mail support or call us at: 1-888-39-THINK (84465)




Supported distributions:

Trisquel 4.01, 4.5, 5, 5.5, 6, 6.01, 7
Parabola GNU/Linux 2013.04.27, 2013.09.01, 2014.06.01, 2014.10.07, 2015.02.21, 2015.02.28, 2015.05.01, 2015.07.01, 2015.08.01, 2015.11.11, 2016.03.17, 2016.06.01, 2016.11.03, 2017.05.28, 2017.09.30
Ubuntu 10.04, 10.10, 11.04, 11.10, 12.04, 12.10, 13.04, 13.10, 14.04, 14.10, 15.04, 15.10, 16.04, 16.10, 17.04, 17.10
Kubuntu 10.04, 10.10, 11.04, 11.10, 12.04, 12.10, 13.04, 13.10, 14.04, 14.10, 15.04, 15.10, 16.04, 16.10, 17.04, 17.10
Lubuntu 10.04, 10.10, 11.04, 11.10, 12.04, 12.10, 13.04, 13.10, 14.04, 14.10, 15.04, 15.10, 16.04, 16.10, 17.04, 17.10
Peppermint Linux OS 1, 2, 3, 4, 5, 6, 7, 8
LXLE 12.04, 12.04.3, 12.04.4, 14.04, discontinued
LinuxMint 9, 10, 11, 12, 13, 14, 14.1, 15, 16, 17, 17.1, 17.2, 17.3, 18, 18.1, 18.2, 18.3
Fedora 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27
OpenSUSE 11.3, 11.4, 12.1, 12.2, 12.3, 13.1, 13.2, Leap 42.1, 42.2, 42.3
PCLinuxOS 2010, 2010.1, 2010.7, 2010.10, 2010.12, 2011.6, 2011.9, 2012.2, 2013.2, 2013.4, 2013.6, 2013.7, 2013.715, 2013.10, 2013.12, 2014.04, 2014.05, 2014.07, 2014.08, 2014.12, 2016.03, 2016.07, 2017.04, 2017.05, 2017.07
Mageia 1, 2, 3, 4, 5, 5.1, 6
Slackware 13.37, 14, 14.1, 14.2
Debian 6, 7, 8, 9
Red Hat Enterprise Linux (RHEL) 7 Series 7.0, 7.1, 7.2, 7.3, 7.4
Red Hat Enterprise Linux (RHEL) 6 Series 6, 6.1, 6.2, 6.3, 6.4, 6.5, 6.6, 6.7, 6.8, 6.9
CentOS 7 Series 7.0, 7.1, 7.2, 7.3, 7.4
CentOS 6 Series 6, 6.1, 6.2, 6.3, 6.4, 6.5, 6.6, 6.7, 6.8, 6.9
Scientific Linux 7 Series 7.0, 7.1, 7.2, 7.3, 7.4
Scientific Linux 6 Series 6, 6.1, 6.2, 6.3, 6.4, 6.5, 6.6, 6.7, 6.8, 6.9
ZorinOS 3.0, 4.0, 5.0, 5.1, 5.2, 6.0, 6.1, 6.2, 7, 7.1, 8, 8.1, 9, 9.1, 10, 11, 12, 12.1, 12.2

In practice all recent distributions are supported.